Hola.

Me estoy iniciando en esto de usar github para nuestros plugins y ahorrarnos el tener que subir por ftp los archivos al hosting.

Con el primer plugin (de personalizar el número de factura), siguiendo las instrucciones del vídeo de Neorazorx de como compartir el vídeo con la comunidad he creado el facturascripts.ini.

En el servidor, me sale que hay una actualización, pero al darle a actualizar me sale el siguiente error:

"Ha habido un error con el archivo update.zip. Código: 19"

Por lo que he leído en el foro es un problema al escribir el zip y en dos ocasiones que se dio, en una se solucionó con un cambio de hosting (en este creo que era un problema global) y en otro con una actualización.

En mi caso, creo que la primera opción no se da, puesto que los plugins propios de facturascripts se actualizan sin problemas y en la segunda no creo, porque me pasa con mi sencillito plugin. Así que lo que debe ser es un fallo en algo.

A ver si alguien puede echarme un cable. El .ini se encuentra en Github

Gracias por anticipado.
hace 4 semanas   shawe   programador nivel 12

Yo a priori no he sabido ver que te falla, pero me indica que el plugin no es compatible y no me carga la descripción, para mi lo veo correcto. Y aunque este no es tu problema con los zip, tienes el siguiente fallo.

Al final de tu facturascripts.ini te falta un:

require = 'facturacion_base'


Porque dependes si o si de ese otro plugin para que funcione tu modificación, puesto que estás haciendo uso de la herencia con un modelo de facturación base, y esta sólo funcionará si el plugin está previamente activado.

hace 4 semanas   NeoRazorX   admin

Lo he instalado, modificado la versión y actualizado sin problemas.
¿Te sigue fallando?

hace 4 semanas   emailforos.es_103

Gracias a los dos pero no se solucionó.

He añadido la configuración de shawe. He vuelto a intentarlo y me da el mismo error.

¿Los plugins "oficiales" de FS se actualizan de igual manera, verdad? Si es así y puedo actualizar los oficiales funcionan y a NeoRazorX le funciona correctamente, algo me falla. ¿Puede ser alguna opción del github?¿Puede ser algún espacio, comilla o algo que esté mal puesta y fastidiando?

He revisado el fichero update.zip que se genera en la raíz de mi alojamiento web (en hosting externo) al intentarlo abrir me da fallo:

7-Zip [64] 9.20  Copyright (c) 1999-2010 Igor Pavlov  2010-11-18
p7zip Version 9.20 (locale=es_ES.UTF-8,Utf16=on,HugeFiles=on,1 CPU)
Error: /tmp/fz3temp-1/update.zip: Can not open file as archive
Errors: 1


He revisado los permisos en el servidor sobre el directorio del plugin y los he comparado con otros plugins "oficiales" que uso como factura_detallada y son idénticos.

Siempre puedo actualizar via ftp pero es una pena teniendo esa funcionalidad disponible.

Muchas gracias de nuevo a los dos.

hace 4 semanas   NeoRazorX   admin

Pues es muy raro, por algún motivo se te descarga mal.
Yo lo que he hecho es descargar e instalar el zip, cambiar el nº de versión y actualizar. Se ha actualizado sin problemas.


Si lo deseas, puedes modificar las prioridades de tus peticiones en el plan de desarrollo.

  Plan de desarrollo