Error al configurar el plugin backup_restore.

Tengo instalado Facturascripts en local y, a la hora de configurar el plugin, me dice que no es capaz de encontrar la herramienta para realizar copia de seguridad ni la de restaurar, pero si comando para restore. En cambio, las tres están en el mismo directorio (C:\AppServ\MySQL\bin).

He tenido que indicar las rutas manualmente:
C:\AppServ\MySQL\bin\mysqldump.exe
C:\AppServ\MySQL\bin\mysql.exe
C:\AppServ\MySQL\bin\mysqlimport.exe

Y al darle a guardar no guarda nada. Probando, probando, cuando he entrado la ruta "C:\\AppServ\\MySQL\\bin\\mysql.exe" (con doble barra inversa) me ha reconocido este como comando para restore, pero no los otros dos. He desinstalado y vuelto a instalar el plugin. No hay manera. Solo he conseguido que me reconozca el comando para restore. Los otros dos no.
¿Alguna idea de qué puede pasar?
Plugin: backup_restore

hace 5 meses   amaniaco_09a8a6
Adjunto captura de pantalla de lo que comentaba.

image
hace 5 meses   shawe   [programador nivel 24]
El problema como comentas en parte es la doble \\ y tenemos pendiente revisarlo, lo detectamos al principio con uno de los testers, pero salvando lo de indicarlo doblado, funcionaba bien y nadie hasta ahora lo ha vuelto a comentar.

Se que Joenilson hizo un arreglo hace poco y puede que haya afectado con lo que comentas. Intentaré hablar con el, pero va a estar fuera hasta finales de mes y no se si podré ponerme yo con ello.
hace 5 meses   amaniaco_09a8a6
Ok, gracias. No es urgente. Andaba probando el plugin y he detectado el error.
hace 4 meses   shawe   [partner]
He visto que JoeNilson ha hecho cambios al respecto, pero no se si ha cambiado algo en relación a tu problema, podrías probarlo e indicarnos si sigue igual el problema?
hace 4 meses   amaniaco_09a8a6
Hola. Iba a descargarme el plugin de nuevo, pero veo que la última versión es del 28-01-2017, la que ya tenía. ¿Se ha subido una nueva actualización?
hace 4 meses   amaniaco_09a8a6
Pues no. Sigue sin funcionar. He de poner la doble barra y solo me detecta Comando para restore. Insisto en el tema de que la versión del plugin que hay para descargar sigue siendo la 5.
hace 4 meses   shawe   [partner]
En el repo desde donde se baja que cuelga de Github marca versión 6: https://github.com/FacturaScripts/backup_restore/blob/master/facturascripts.ini
Y en la comunidad veo que también:
https://www.facturascripts.com/plugin/backup_restore

No se porqué véis sólo la 5, esta tarde lo hablo con JoeNilson a ver si el sabe ver que sucede.
hace 4 meses   amaniaco_09a8a6
Pues será algo de proxys, caché o vete a saber... lo he vuelto a descargar desde el enlace y sigue apareciendo la versión 5. Y, sí, desde Github veo que la última modificación fue hace cinco días, pero desde el apartado de plugins sigue saliendo la versión anterior.

image
hace 4 meses   shawe   [partner]
Amaniaco ahora si descarga la última versión, se estaba forzando a descargar siempre la v5 desde el facturascripts.ini de dentro del zip
hace 4 meses   shawe   [partner]
La actualización ya debería funcionar correctamente, aunque no se si realmente termina arreglando el inicio de esta consulta, ya que fue JoeNilson quien estuvo haciendo arreglos, pero no se que hizo exactamente.
hace 4 meses   amaniaco_09a8a6
Ahora se actualiza a la versión 6, pero sigue existiendo el mismo problema. Solo me reconoce la ruta del Comando para restore. Del resto, nada de nada. Ni con barra simple ni doble. He desinstalado el plugin, lo he vuelto a instalar, he limpiado la caché... no me coge la ubicación del mysqldump ni el mysqlimport. ¿Alguna idea que pueda probar? Se me ocurría si fuera algo de las variables de entorno de Windows, pero veo que no hay nada raro y apuntan a la ubicación del MySql.

image
hace 4 meses   shawe   [partner]
Pudiste probar lo último que te comenté?
hace 4 meses   amaniaco_09a8a6
Instalé la actualización, ahora tengo la versión 10, pero sigue sin cogerme las rutas de los archivos. Conseguí forzar la ruta de Comando para backup poniéndolo con doble barra y entrecomillado a la hora de entrar la configuración de la ruta de archivo. Pero solo me lo cogió aquí.

image
hace 4 meses   shawe   [partner]
Disculpa, me equivoqué de hilo al preguntarte. En otro hilo que abriste te comente de utilizar este empaquetado: https://bitnami.com/redirect/to/146063/bitnami-wappstack-7.1.2-1-dev-windows-installer.exe.

Prueba a hacer un backup completo, instala este empaquetado, detén el servidor web Apache y MySQL de tu empaquetado actual, y copia la carpeta pública de tu anterior Apache al del Apache de WappStack, create la base de datos en el nuevo servidor de MySQL (a ser posible con la configuración que ya usas en tu config.php de FS) e intenta activar sólo el plugin backup_ restore y comprobar si detecta bien el sólo las rutas, si lo hace, restaura el backup que acabas de hacer y prueba que todo funcione correcto. Si funciona bien, te sugiero dejar de utilizar el anterior y continuar con este.

No se exactamente qué causa tu problema con las rutas, es un caso a estudiar (pero por ahora parece un caso aislado), es demasiado complejo encontrar soluciones para los distintos servidores web para Windows (y de hecho en el instalador de FS ya se indica que sólo se da soporte para el empaquetado oficial), ya que cada empaquetado está configurado diferente y con extensiones diferentes. Como te comenté en el otro hilo, yo he usado WAPP en 3 o 4 instalaciones diferentes y nunca me ha dado ningún problema al respecto ni con ninguna otra cosa.

Si es el empaquetado oficial de FacturaScripts, necesitaríamos saberlo para que el partner que lo preparó lo pueda revisar y solucionar, porque sino dejarás de ser un caso aislado.
hace 4 meses   amaniaco_09a8a6
Ok. Ya haré las pruebas que me dices y te informo con lo que sea.
hace 4 meses   amaniaco_09a8a6
No ha hecho falta hacer las pruebas que me indicabas, con la versión 11 del plugin parece ser que está solucionado. Me ha cogido la configuración sin problema. He hecho una copia de la BBDD y de los archivos y ha funcionado. Probaré luego de hacer una restauración de los datos, pero parece ser que ahora la cosa va.
hace 4 meses   shawe   [partner]
Pues si se te ha arreglado con la v11, no se ha tocado nada al respecto de este problema :S
No se pueden hacer más comentarios. Mejor escribe una nueva pregunta

Financiación extra

13 patrocinadores

Este mes se han realizado un total de 13 aportaciones económicas para acelerar el desarrollo del proyecto.

34% Complete

170 € este mes. Puedes aumentar estas cifras ;-)

+5 € +4 votos

+25 € +20 votos




Soporte

FacturaScripts es software libre y gratuito, pero si lo que busca es asesoramiento y soporte profesional, use la sección soporte. Encontrará el partner apropiado para el trabajo apropiado.

  Soporte

O síganos en las redes sociales.





© 2013-2017 FacturaScripts