Esta consulta es de hace 2 años. Tenga eso en cuenta.
Esta web utiliza cookies propias y de terceros para su funcionamiento. ¿Aceptas? Leer más
amaniaco_09a8a6
amaniaco_09a8a6
Error expedientes cerrado

Dos cosas que veo tras instalar el plugin Expedientes......

Dos cosas que veo tras instalar el plugin Expedientes...

¿Sería posible que todos los documentos adjuntos estén en la misma carpeta? Ahora veo que hay dos carpetas, una llamada documentos (que se instala por defecto con FacturaScripts) y otra documentos_adjuntos (que aparece tras instalar el plugin de expedientes). Lo comento porque, a nivel de copias de seguridad, sería más lógico que todo estuviera junto.

Y yendo al tema del plugin de Expedientes, veo que al acceder en Albaranes, cuando le doy a la pestaña Expediente, devuelve este error:

Fatal error: Call to undefined method servicio_cliente::all_from_albaran() in C:\AppServ\www\amaniaco\plugins\expedientes\controller\tab_expedientes_docs.php on line 1003

No ocurre en Pedidos ni en Facturas.

Y, en los listados de Pedidos y Albaranes, aparece el icono conforme hay un archivo adjunto pero, al acceder a dicho documento, no aparece el archivo adjunto por ningún sitio.

Pasa lo mismo con los adjuntos previos a la instalación del plugin Expedientes, pero no ocurre en Facturas, aquí aparecen los archivos.
Plugin: expedientes

España   28-03-2017 18:27:28   10-04-2017 10:45:41   1   [shawe]

Comentarios
shawe
Los documentos adjuntos están en 2 carpetas diferentes porqué son 2 plugins diferentes, uno es el "documentos_facturas" y el otro es "expedientes". Inicialmente el de dentro de "expedientes" era un fork de "documentos_facturas" con soporte para añadir adjuntos además a un expediente en concreto sin pasar por ningún documento en concreto, y poco a poco se ha ido modificando su interfaz para añadir también notas de forma directa y para visualizar todos los archivos soportados de forma directa sin tener que cargar una página nueva mediante una librería de terceros. Así que con las diferencias visuales palpables y para evitar confusiones a los usuarios, se optó por ni compartir la tabla con el plugin "documentos_facturas", ni compartir la carpeta, para que cada cual trabaje de forma independiente sin interferir entre sí y sin ser un plugin que genere dependencia.

El error que describes es porqué has encontrado un bug, el plugin de "servicios" es opcional, pero inicialmente lo añadí como si no lo fuese, cosa que poco a poco he ido corrigiendo, pero ya veo que todavía se me ha escapado en ese lugar, ese tiene fácil arreglo ;) Pero viendo que se me ha escapado, veo que debo hacer una batida completa para evitar que se vuelva a quedar otro. Por el momento para no ver ese error, puedes instalar y activar "servicios" hasta la próxima actualización y luego desinstalar-lo. El problema es debido a que un albarán puede provenir de un servicio y se están intentando leer los albaranes que provienen de servicios sin tenerlo instalado, cosa que sin dicho plugin no es posible.

Sobre el adjunto, te refieres al icono del clip? Si es así, mira el mensaje que hay poniendo el cursor encima, porqué sale la descripción de lo que indica y es que el documento está aprobado al siguiente tipo de documento, y en facturas no lo ves porqué no tiene ningún asiento contable, que es cuando aparece. Es de la misma forma que lo hacen las listas originales de presupuestos, pedidos, servicios, albaranes y facturas para evitar que haya confusiones. Para mi el icono no es el más apropiado, pero ya digo que he usado el mismo estilo que los listados originales para no causar confusiones. Si te fijas desde ventas_pedidos por ejemplo, veras que la tabla respeta esos iconos, y los documentos adjuntados con "documentos_facturas" lo indica entre el nombre del cliente y las observaciones. A mi gusto personal deberían intercambiarse los iconos de los documentos adjuntos y los aprobados para evitar este tipo de confusiones visuales y conceptuales.
image


Si crees que no te he entendido bien en algo, corrígeme en lo que creas oportuno, y la corrección tan pronto como pueda revisarlo de nuevo a fondo la libero, no quisiera que os topéis de nuevo con un problema como este.
shawe
Puse mal la imagen incrustada, es esta:

image
amaniaco_09a8a6
Ok, gracias. Te ampliaré la información y, si te parece, voy trasteando por si veo algo más.
shawe
Sin problemas, yo acabo de ver otro fallo gracias al reporte que me has hecho y a la imagen que te he adjuntado, al sumar divisas diferentes, el total "no es un numero" porque tal y como lo tengo preparado, asume que todos los precios están en 1 sola moneda.

Esto ha sido un 2 en 1 xDDD
amaniaco_09a8a6
No te preocupes. Te estoy haciendo unas capturas de pantalla para explicar el error. Cuando me refiero al icono, estoy hablando del listado de Albaranes general, sin entrar todavía en Expedientes. En el listado, cuando un albarán tiene un archivo adjunto aparece un icono de una hoja de papel con la esquina superior doblada. Pues bien, cuando examinas ese albarán, tienes una pestaña de Documentos adjuntos y otra pestaña con ese mismo icono (el de la hoja con la esquina superior doblada), en ninguna de las dos aparece el archivo.
Supongo que la primera pestaña es para todo lo que se añada a partir de ahora que está el plugin Expedientes y que, la otra pestaña, es por compatibilidad con lo que ya había, pero en ninguna de las dos aparece, todo y que en el listado aparece que el albarán lleva incorporado un archivo.



image
amaniaco_09a8a6
En el listado aparece el icono, pero no aparece el adjunto.

image
amaniaco_09a8a6
Ni en la nueva pestaña de Documentos adjuntos.

image
amaniaco_09a8a6
Espero que te haya aclarado lo que comentaba de los adjuntos desaparecidos. Cualquier cosa me dices y hago las pruebas que consideres. Un saludo.
shawe
El documento adjunto te lo indica ventas_albaranes, y no es de la pestaña "Documentos adjuntos" sino de la pestaña con sólo el icono de documento que es "documentos_facturas".

Desactiva el plugin "documentos_facturas", "gestion_documental", "expedientes" (uno a uno a ser posible, y no ambos a la vez), y mira si sigue apareciendo ese adjunto en la lista de ventas_albaranes, pero desde luego en esa lista, yo no he metido mano para indicar que hay adjuntos, precisamente porqué ahí no es sencillo añadir información en forma de "extensión" que es lo correcto que hagamos. Al desactivar el plugin que causa el fallo, deberías dejar de ver que se indique ese adjunto al documento.

Los adjuntos a través de "Expedientes" se pueden ver desde el propio documento y/o desde la pestaña "Documentos adjuntos" en el propio expediente.

Le he comentado a NeoRazorX que se pase para confirmar si el fallo está en "documentos_facturas" y/o "facturacion_base"/"presupuestos_y_pedidos", y me ha dicho que revises lo indicado en mi segundo párrafo.
shawe
No hace falta que hagas pruebas, ya he visto el fallo del adjunto y ha sido un poco sin querer mediante las capturas de pantalla.

Si desactivas "Expedientes" verás que tu pestaña de "Documentos" cambiará su presentación (ahora ambas son iguales), no me di cuenta que llamé a la pestaña de la misma forma, y por tanto se carga el contenido de la del plugin que se ha activado último.

Tan pronto como me sea posible lanzo actualización solucionando los 2 bugs que has encontrado ;)
amaniaco_09a8a6
¡Perfecto! ¿Seguro que no quieres que haga alguna prueba? Si veo algo te aviso. Por otra parte, felicitaros tanto a NeoRazorX y a ti por el trabajo que hacéis.
shawe
Pruebalo si quieres, pero ahora si está localizado el problema de los adjuntos ;) así que solo verás los adjuntos previos al desactivar Expedientes.

Todos intentamos que tengáis la mejor experiencia posible dentro de nuestras posibilidades.
shawe
Ha falta de probarlo a fondo, está solucionado.
-
[[Cerrado por inactividad]]

Cerrado
otros
Título Tipo
amaniaco_09a8a6 NeoRazorX
Me ha desaparecido un proveedor.He entrado en Proveedores/Acreedores y he buscado su nombre y no aparecía. Me ha extrañado porque trabajo bastante con él y no salía. Lo he mirado en el listado...
cerrado 30-05-2017 11:28:06
Error 2
amaniaco_09a8a6 shawe
Plugin: backup_restore La versión del plugin que hay disponible para descargar sigue siendo la versión 5, todo y que está anunciada una nueva actualización. ¿Es un error mío o le ocurre a alguien...
cerrado 02-05-2017 09:50:06
Error 5
amaniaco_09a8a6 amaniaco_09a8a6
Error al instalar el plugin Expedientes. Acabo de instalar el plugin y, nada más activarlo me da error: Error al ejecutar la consulta 0: Cannot add foreign key constraint. La secuencia ocupa la...
cerrado 24-03-2017 22:06:26
Error 9
amaniaco_09a8a6 shawe
Error al configurar el plugin backup_restore. Tengo instalado Facturascripts en local y, a la hora de configurar el plugin, me dice que no es capaz de encontrar la herramienta para realizar copia...
cerrado 16-06-2017 11:08:33
Error 18
amaniaco_09a8a6
Cuando creas una nota coge, por defecto, la fecha actual. Estaría bien, en el caso de entrar notas a modo de informe tras visitar a los clientes, que puedas indicar manualmente la fecha. A veces...
cerrado 04-01-2017 01:05:19
Idea 0
amaniaco_09a8a6 NeoRazorX
Acabo de actualizar de la versión 11 a la 12 del plugin CRM y, desde la ficha de clientes, al acceder a contactos devuelve este error: Fatal error: Call to a member function all_from_cliente() on...
cerrado 07-10-2016 12:56:16
Error 2
amaniaco_09a8a6 nathoo
A la hora de adjuntar un documento en clientes / proveedores, si el nombre del archivo contiene acentos (20130627 - Factura sobres enví­o suscripciones.pdf), al intentar recuperarlo da error: The...
cerrado 20-06-2016 23:49:42
Error 1