Esta web utiliza cookies propias y de terceros para su funcionamiento. ¿Aceptas? Leer más
Esta consulta es de hace más de un año. Tenga eso en cuenta.
facturascripts_303fd2
facturascripts_303fd2
Error facturae cerrado

Plugin: facturae Hola! He actualizado a la última...

Plugin: facturae

Hola! He actualizado a la última versión, ya que había hecho una pregunta sobre las observaciones que no se incluyen en factura electrónica, y al ir a probar la factura-e, tanto al "firmar" como al "preparar", me da la pantalla en blanco.

Esto es lo que me da el log de apache:

PHP Parse error: syntax error, unexpected '.', expecting ',' or ';' in /miweb_com/plugins/facturae/vendor/josemmo/facturae-php/src/Controller/FacturaeConstants.php on line 12, referer: https://www.miweb.com/index.php?page=facturae&id=7

Me lo hace en chrome, opera y firefox.

España   04-09-2018 17:38:50   10-09-2018 01:08:18   20   [NeoRazorX]

NeoRazorX
Hola, muchas gracias por informar. Intentaré tener la actualización lista mañana.
Disculpa las molestias.
facturascripts_303fd2
Genial, gracias!
NeoRazorX
Disculpa la tardanza. ¿Qué versión de PHP estás usando?
facturascripts_303fd2
Hola!

PHP Version 5.4.16
NeoRazorX
Realmente la versión 5.4 ya se quedó obsoleta en 2015. Creo que somos el único proyecto que todavía da soporte, pero por poco tiempo.
Con los últimos cambios en el plugin facturae, ahora este plugin necesita como mínimo PHP 5.6.

Si puedes actualiza a PHP 7.0, que es el nuevo mínimo para casi todos los proyectos PHP actuales. Además de que ofrece en muchos casos más de un 100% de rendimiento frente a PHP 5.4.
facturascripts_303fd2
Si, es verdad. Asumo la responsabilidad plena de este problema, de hecho, lo raro es que funcione. Gracias por su ayuda! En cuanto actualice esto (mañana mismo) y pueda enviar las observaciones en la factura-e, ya podré operar a pleno rendimiento!
facturascripts_303fd2
CERRADO
Cerrado