Plugin: facturacion_base

Amigos, llevo todo el día intentando configurar para enviar una factura desde el programa y no hay forma.

Lo tengo con 1and1.es... pero no me funciona ni con dominio propio, ni con gmail, ni hotmail.. nada de nada.. me dice siempre que la clave no puede conectar...

He probado incluso, lo que mencino transporte_103 abajo expuesta, pero sigue igual...

En localhost funciona perfecto, pero no me funciona.. he leido que es problema de 1and1, pero ¿no hay ninguna solución que no sea cambiar de servidor?

Gracias por la ayuda...



La unica opcion en 1and1.es es anularle en /extras/phpmailer/class.phpmailer.php
718 public function isSMTP()
719 {
720 $this->Mailer = 'smtp'; Cambia por lo que quieras $a=" ";
721 }
hace 2 meses   NeoRazorX   admin

Esto no es un error de FacturaScripts, porque realmente la modificación que propones usa la función mail de php, que solamente funciona si está configurada en el servidor y uso el email del servidor, no gmail, ni hotmail. Pero voy a darle una vuelta para ponerlo como opción.

hace 2 meses   emiliomartinacevedo_103

Perdonen... al leer mi mensaje me he dado cuenta de que no he dicho que lo que intento es enviar una factura de cliente por email. Configurando previamente en el apartado empresa los datos de configuración, pero me da siempre error.

Sin embargo, en localhost, no me falla.

Gracias.

hace 2 meses   emiliomartinacevedo_103

Gracias por contestar.. pero mi pregunta.. imagino que habra alguno usando FacturaScripts con 1and1... ¿como lo han solucionado?.... he leido mucho sobre el tema, pero no logro entender como resolverlo...

te adjunto la imagen de la opción de la que hablamos.. donde en teoria se puede usar otras como gmail...

no hagas caso a la configuración que esta en la imagen, le he cambiado los valores mil veces pero siempre da error....


image

hace 2 meses   NeoRazorX   admin

Con tls y puerto 25 suele funcionar. Lo que pasa es que cada usuario de 1and1 suele estar en un servidor con una configuración distinta, y lo que funciona para uno está bloqueado para otro.

De todas formas marca lo de permitir certificados poco seguros.

hace 2 meses   emiliomartinacevedo_103

Esta probado pero no hay forma... llevo todo el día peleandome con esto :-((((((

hace 2 meses   emiliomartinacevedo_103

Amigo.. te adjunto la configuración con la que funcona perfectamente por ejemplo en thunderbird.

De todas formas, si quieres hacer pruebas y buscar la solución, yo estoy dispuesto a darte todos los datos que necesites...

En fin... tienes alguna configuración de correo que sea pública y que funcione bien para yo probar? no se.. para descartar...
image

hace 2 meses   NeoRazorX   admin

La verdad es que no importa como tengas configurado thunderbird, porque eso es desde fuera, y el problema lo tienes al conectar desde el propio servidor. Por eso en local te funciona.

Ya he terminado los cambios para soportar más tipos a parte de smtp. Seguramente la publique mañana.

hace 2 meses   emiliomartinacevedo_103

Ok .. quedo a la espera... muchas gracias.

hace 2 meses   ezequieltotoras_103

Hola, los smtp son diferentes, en la primer imagen esta "smtp.1and1.es" Puerto 25 y en el Thunderbird "smtp.1und1.de" Puerto 587

Saludos

hace 2 meses   ezequieltotoras_103

Aca especifica los puertos utilizados, tal vez te sirva:
https://ayuda.1and1.es/correo-c64733/1y1-correo-electronico-c85123/para-comenzar-c64734/datos-necesarios-para-configurar-clientes-de-correo-a694503.html

hace 2 meses   NeoRazorX   admin

Actualiza, ya tienes mail y sendmail como una opción de envío en admin -> empresa -> email.

hace 2 meses   emiliomartinacevedo_103

Ok, excelente.. lo acabo de probar, y por ejemplo con gmail me ha funcionado perfecto.

Hago pruebas y te cuento.

Por cierto, con la factura simple me ha ido bien, pero la factura detallada se ha quedado pensando, y al final me ha dado un mensaje de error.

Voy a probarlo todo.. y al final te cuento. Muchas gracias crack.

hace 2 meses   emiliomartinacevedo_103

Buenas noches,

He comprobado con 1and1.es, sync.es,hotmail(outlook) y gmail, y todos funcionan perfecto... o casi.

Ya no da ningún error en Empresa.. y la única incidencia la he encontrado al tratar de enviar la "factura detallada", la simple la hace perfecta.

Por cierto, una duda a este respecto, si en una factura ( o otro documento ) tengo algún documento adjunto ¿no debería enviarlo junto con la factura? ...o eso es opcional?

Nuevamente, gracias.. si necesitas alguna prueba más avisa.. saludos.

hace 2 meses   hlopez_105

No te envía adjuntos solo la factura el formato que elijas y así mismo el resto de documentos en el formato que elijas

hace 2 meses   emiliomartinacevedo_103

Gracias por contestar hlopez_105. Sería interesante añadirlo. me explico.. igual este no es el hilo... pero.. hay empresas que envia una ficha técnica de un articulo, y otros pdf junto con cada envio de material. ( en estos casos, seria cuestión de añadir en articulos la opción de marcar si un determinado adjunto debe acompañar los documentos), y en otros casos, es en el mismo momento de hacer el albaran o factura, donde se adjuntan documentos... todo estos se pueden añadir manualmente, pero si se tiene la opción no estaría mal.

Bueno... lo que si .. que se queda colgado al enviar la factura detallada,

hace 2 meses   NeoRazorX   admin

Bueno, solemente queda actualizar factura_detallada.

No se pueden hacer más comentarios. Mejor escribe una nueva pregunta