Los recibos me los duplica, los borro y los vuelve a crear, lo pago y aparece sin pagar.... en fin que me llevan loco....
Detectado plugin no oficial: Imprimir. Si tienes problemas, desactívalo para comprobar si es la fuente del problema.
Detectado plugin no oficial: informes. Si tienes problemas, desactívalo para comprobar si es la fuente del problema.
Detectado plugin no oficial: fabricacion. Si tienes problemas, desactívalo para comprobar si es la fuente del problema.
hace 2 meses   NeoRazorX   admin

El plugin se usa a diario en un montón de empresas sin encontrar este tipo de fallos. Sin detalles y ejemplos este informe no sirve de nada. ¿O también tengo que hacer de detective?

Me estáis dando un mes horrible, cada pregunta o informe de error es más corto que el anterior. A este paso la semana que viene los informes de error serán: "Me da un error ¿Qué puede ser?", y dentro de un mes será una línea en blanco y habrá que imaginar lo que pone...

Y puedo entender que un novato llegue a escribir una sola línea en plan, "me falla", ala, ya está. Pero que también lo hagáis los que lleváis más tiempo y sabéis que encontrar un error sin ningún dato es como encontrar una aguja en un pajar, es algo que me enciende.

Me gusta tener un trato directo con el usuario a la hora de solucionar errores, pero este mes la sección de errores no sirve para nada. Y si esto va en aumento, directamente la eliminaré.... si al final me toca generar datos aleatorios para encontrar esos casos donde falla... para eso no hace falta esta sección.

hace 2 meses   juanicos_111

Te entiendo y te pido disculpas... detecte estos problemas en estas últimas actualizaciones, pero no he conseguido detectar las situaciones concretas. A veces pasa y a veces no (seguramente tenga que ver con las caches...).

Unas veces (no se cuando ni porque) marco un recibo como pagado, todo parece bien, pero luego tengo el recibo pagado y otro sin pagar (el mismo), si lo elimino (o los dos, el pagado y el sin pagar) me genera automáticamente otro, a veces pago este nuevo y todo ok, otras se repite el proceso.

En este último caso, me pasó con un recibo lo dicho y con otra factura, lo tenia configurado con dos pagos, no estoy seguro, pero creo que eliminé los dos recibos y creé uno por el importe de ambos (sin cambiar el modo de pago), con lo que me encontré con 3 recibos, el del total y los 2 pagos (esto lo veo normal, fallo mío). Tras probar (espesito que está uno), cambié la forma de pago a un solo recibo, y estuve borrando recibos, para quedarme con uno solo... el caso es que se le fue la pinza y cada vez tenía mas recibos (todos iguales, mismo número de recibo, etc...). Desactivé el plulgin y lo volví a activar... mas recibos duplicados... ahí fue que te envié el informe ... frustación, sorry.

Al final, limpie cache de FS y del navegador. Los borre con phpmyadmin, y a partir de ahí todo ok (de momento).

Ahora parece que va bien, si detecto que vuelve a pasar intentaré ser de más ayuda.

hace 2 meses   NeoRazorX   admin

Los recibos solamente se regeneran si no hay recibos y la factura está sin pagar, o si se pulsa el botón regenerar. Además se comprueba en todo momento el saldo pendiente.
Obviamente puede haber errores, pero sin ejemplos que fallen no veo forma de detectar el error más allá de probar y probar...

Cuando te falle, foto y adjunta a comentarios.

hace 2 meses   juanicos_111

No se si aporta algo, he marcado como pagados 3 recibos, el primero bien y los otros 2 tururu... pero no se que pasa.

Y ahora mismo, he probado con varios. lo marco como pagado y se refresca la pantalla como pagado, recargo o me voy a la lista de recibos y aparece como no pagado, pero el asiento está....

Lo único es que he actualizado... puede tener algo que ver ????
image

hace 2 meses   juanicos_111

Mira este es otro recibo que ha fallado. He borrado el asiento, y luego el recibo. Luego he ido a la factura, me meto en recibos y me encuentro esto (foto adjunta).

Te pego el sql, por si aporta algo:



SHOW TABLES;
SELECT * FROM fs_pages WHERE name = 'ventas_recibos';
UPDATE fs_pages SET title = 'Recibos', folder = 'ventas', version = '2016.022', show_on_menu = TRUE, important = FALSE WHERE name = 'ventas_recibos';
SELECT * FROM fs_vars;
SELECT * FROM fs_extensions2 ORDER BY text ASC;
SELECT * FROM fs_users WHERE nick = 'admin';
SELECT * FROM fs_pages ORDER BY lower(folder) ASC, lower(title) ASC;
SELECT * FROM facturascli WHERE idfactura = '15494';
SELECT * FROM reciboscli WHERE idfactura = '15494' ORDER BY fechav ASC
SELECT * FROM fs_vars;
SELECT * FROM reciboscli WHERE idfactura = '15494' ORDER BY fechav ASC
SELECT * FROM facturascli WHERE idfactura = '15494';
UPDATE facturascli SET idasiento = '2606', idasientop = NULL, idfacturarect = NULL, codigo = '20160B000175', numero = '175', numero2 = '', codigorect = NULL, codejercicio = '2016', codserie = 'B', codalmacen = 'ALG', codpago = 'CONT', coddivisa = 'EUR', fecha = '2016-09-30', codcliente = '000573', nombrecliente = 'FORMULA CAR AUTOMOCION', cifnif = '0', direccion = '', ciudad = '', provincia = '', apartado = '', coddir = NULL, codpostal = '', codpais = 'ESP', codagente = '1', neto = '89', totaliva = '0', total = '89', totaleuros = '89', irpf = '0', totalirpf = '0', porcomision = '0', tasaconv = '1', totalrecargo = '0', observaciones = '', pagada = FALSE, anulada = FALSE, hora = '17:18:46', vencimiento = '2016-10-01', femail = NULL, codtrans = NULL, codigoenv = '', nombreenv = '', apellidosenv = '', apartadoenv = '', direccionenv = '', codpostalenv = '', ciudadenv = '', provinciaenv = '', codpaisenv = 'ESP', idimprenta = NULL WHERE idfactura = '15494';
SELECT * FROM divisas WHERE coddivisa = 'EUR';


image

hace 2 meses   juanicos_111

Perdona, ahora le he dado a regenerar, me deja solo uno, luego lo pongo pagado y OK.

hace 2 meses   hlopez_105

Offtopic - Por la seguridad de tu instancia deberías usar login_anonimo y dejar de ver el sql

hace 2 meses   NeoRazorX   admin

¿Cuál es el importe de esa factura?

hace 2 meses   juanicos_111

89€

hace 1 mes   imprentasa_111

Esto sigue haciendo lo que quiere, menudo follón arrastro con los recibos. Llevo usando Tesorería un montón de tiempo y no he tenido estos problemas hasta las últimas actualizaciones. Pero entiendo que si a nadie más le pasa, es algo que no anda bien en mi sistema.

No termino de pillar una relación causa-efecto que pueda ayudar, a veces funciona y a veces no.

Algo que si he detectado es que tengo problemas con los permisos. Uso ispconfig, y tengo instalado facturascript en un dominio asigando al usuario web2, el caso es que los temporales y alguno más me aparecen como que pertenecen a www-data y esto crea problemas en FS. Me he dado cuenta al intentar desactivar plugins, que no me dejaba. Lo comento por si puede tener relación con los recibos.

Le he dado permisos de escritura+ejecución a todo el grupo, con eso parece que de momento funciona.

Si me puedes dar alguna pista de que puedo hacer... ya te digo que tiene que ver con los cambios que hicieras en las últimas actualizaciones... o algo que no esté bien instalado o configurado en mi sistema a partir de actualizar esas versiones.

He desactivado todos los modulos y vuelto a activarlos, pero sigue igual.

hace 1 mes   NeoRazorX   admin

Revisé el código y no encontré problema. No creo que sea cosa de permisos.
Por desgracia ya agoté, y mucho, el tiempo de desarrollo para ese plugin, y voy muy apurado de tiempo para terminar woocommerce y prestashop.
Cuando los termine vuelvo a revisarlo.

hace 1 semana   juanicos_111

También afecta a la edición del recibo, le cambio el importe y aparece cambiado (en la base de datos comprobado también) pero luego actualizo la página y tururu.. está como estaba. Insisto varias veces hasta que se lo traga, y a partir de ahí funciona sin problemas, para futuras ediciones de recibos.

Por si aporta algo nuevo.

hace 2 días   NeoRazorX   admin

Solucionado. Estará en la actualización de esta tarde.


Si lo deseas, puedes modificar las prioridades de tus peticiones en el plan de desarrollo.

  Plan de desarrollo