hace 11 días   socger_f74d39
Error al hacer composer install sobre la última subida realizada
Paso imagen copiada
hace 11 días   socger_f74d39
SocGer@JERO-PORTATIL-P c:\COMPARTIENdo\TRABAJANDOSE\PROYECTOS REALIZANDOSE\PHP\xampp\htdocs\facturascripts\2018 NeoRazorX\facturascripts
# composer install
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 35 installs, 0 updates, 0 removals
- Installing rospdf/pdf-php (dev-master 9948163): Cloning 9948163b7c from cache
- Installing mk-j/php_xlsxwriter (dev-master 34188d1): Cloning 34188d1aef from cache
- Installing symfony/polyfill-mbstring (v1.6.0): Loading from cache
- Installing symfony/http-foundation (v3.3.11): Loading from cache
- Installing symfony/translation (v3.3.11): Loading from cache
- Installing twig/twig (v1.35.0): Loading from cache
- Installing symfony/var-dumper (v3.3.11): Loading from cache
- Installing psr/log (1.0.2): Loading from cache - Installing maximebf/debugbar (v1.14.1): Loading from cache
- Installing symfony/event-dispatcher (v3.3.11): Loading from cache
- Installing symfony/yaml (v3.3.11): Loading from cache
- Installing sebastian/version (2.0.1): Loading from cache
- Installing sebastian/resource-operations (1.0.0): Loading from cache
- Installing sebastian/recursion-context (2.0.0): Loading from cache
- Installing sebastian/object-enumerator (2.0.1): Loading from cache
- Installing sebastian/global-state (1.1.1): Loading from cache
- Installing sebastian/exporter (2.0.0): Loading from cache
- Installing sebastian/environment (2.0.0): Loading from cache
- Installing sebastian/diff (1.4.3): Loading from cache
- Installing sebastian/comparator (1.2.4): Loading from cache
- Installing doctrine/instantiator (1.1.0): Loading from cache
- Installing phpunit/php-text-template (1.2.1): Loading from cache
- Installing phpunit/phpunit-mock-objects (3.4.4): Loading from cache
- Installing phpunit/php-timer (1.0.9): Loading from cache
- Installing phpunit/php-file-iterator (1.4.2): Loading from cache
- Installing sebastian/code-unit-reverse-lookup (1.0.1): Loading from cache
- Installing phpunit/php-token-stream (2.0.1): Loading from cache
- Installing phpunit/php-code-coverage (4.0.8): Loading from cache
Failed to download phpunit/php-code-coverage from dist: The archive may contain identical file names with different capitalization (which fails on case insensitive filesystems): ZipArchive::extractTo(C:\COMPARTIENdo\TRABAJANDOSE\PROYECTOS REALIZANDOSE\PHP\xampp\htdocs\facturascripts\2018 NeoRazorX\facturascripts/vendor/composer/a057ccb9/sebastianbergmann-php-code-coverage-ef7b2f5\tests\_files\Report\HTML\CoverageForClassWithAnonymousFunction/dashboard.html): failed to open stream: No such file or directory
Now trying to download from source
- Installing phpunit/php-code-coverage (4.0.8): Cloning ef7b2f5681 from cache


[RuntimeException]
Failed to clone https://github.com/sebastianbergmann/php-code-coverage.git via https, ssh protocols, aborting.
- https://github.com/sebastianbergmann/php-code-coverage.git
fatal: destination path 'C:\COMPARTIENdo\TRABAJANDOSE\PROYECTOS REALIZANDOSE\PHP\xampp\htdocs\facturascripts\2018 NeoRazorX\facturascripts\vendor\phpu
nit\php-code-coverage' already exists and is not an empty directory.
- git@github.com:sebastianbergmann/php-code-coverage.git
fatal: destination path 'C:\COMPARTIENdo\TRABAJANDOSE\PROYECTOS REALIZANDOSE\PHP\xampp\htdocs\facturascripts\2018 NeoRazorX\facturascripts\vendor\phpu
nit\php-code-coverage' already exists and is not an empty directory.


install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--] [<packages>]...


SocGer@JERO-PORTATIL-P c:\COMPARTIENdo\TRABAJANDOSE\PROYECTOS REALIZANDOSE\PHP\xampp\htdocs\facturascripts\2018 NeoRazorX\facturascripts
#
hace 11 días   NeoRazorX   [admin]
Parece que falla al descargar php-unit, pero no es demasiado problema, solamente lo utilizamos para lanzar pruebas.
Puedes continuar aunque no esté.
hace 11 días   socger_f74d39
Perdona Carlos, pero cuando haces la llamada al localhost del directorio donde acabas de hacer el git clone y el composer install ...
pues nos da un error con la línea 36 de install.php

Y es porque no puede cargar (el require) /vendor/autoload.php

Así que lo he solucionado tirando de un versión old que hice de facturascripts donde copié todo el directorio vendor y lo llevé a donde no me funcionó el composer install

Es una chapuza porque no tenemos el último código de todo lo de vendor ... pero funciona
Ya comprobaré más adelante si todo continua sin descargarse bien
hace 11 días   socger_f74d39
Por cierto, he hecho dos pruebas con github del proyecto que no quisiera que actualizaras, una porque es código old que modifiqué y la última es una actualización de prueba de funcionamiento de git. Todavía estoy aprendiendo el funcionamiento de github así que no subiré nada más hasta que no sepa como funciona correctamente
Pero sigo entendiendo el código antes de apoyar más ..

Saludos
No se pueden hacer más comentarios. Mejor escribe una nueva pregunta

socger_f74d39

ES  programador


OFERTA

Plugin prestashop_micro

Financiación extra

23 patrocinadores

Este mes se han realizado un total de 23 aportaciones económicas para acelerar el desarrollo del proyecto.

70% Complete

350 € este mes.

+5 € +4 votos

+25 € +20 votos




Soporte:

FacturaScripts es software libre y gratuito, pero si lo que busca es asesoramiento y soporte profesional, use la sección soporte.

  Soporte

¿Desea ser distribuidor?

Si desa ser distribuidor oficial de FacturaScripts, comience hoy mismo el proceso.

  hágase partner

Redes sociales:

Puede encontrarnos en las principales redes sociales. Y también en google+.





© 2013-2017 FacturaScripts