hace 27 días   aptelcsc_f74d39
Disculpen soy algo novato en esto. Pero al actualizar el sistema me tira este error. Se que lo solucion esta aqui, pero no logro verla

Tipo: 1
Archivo: /var/www/html/facturascripts_2015-master/base/fs_model.php
Línea: 466
Mensaje: Uncaught Error: Call to undefined function simplexml_load_string() in /var/www/html/facturascripts_2015-master/base/fs_model.php:466 Stack trace: #0 /var/www/html/facturascripts_2015-master/base/fs_model.php(408): fs_model->get_xml_table('fs_users', Array, Array) #1 /var/www/html/facturascripts_2015-master/base/fs_model.php(111): fs_model->check_table('fs_users') #2 /var/www/html/facturascripts_2015-master/model/core/fs_user.php(126): fs_model->__construct('fs_users') #3 /var/www/html/facturascripts_2015-master/base/fs_controller.php(164): FacturaScripts\model\fs_user->__construct() #4 /var/www/html/facturascripts_2015-master/plugins/facturacion_base/controller/dashboard.php(38): fs_controller->__construct('dashboard', 'Dashboard', 'informes', false, true, true) #5 /var/www/html/facturascripts_2015-master/index.php(63): dashboard->__construct() #6 {main} thrown
hace 1 mes   aptelcsc_f74d39
He querido editar el fichero fs_model.php Aqui un pantallazo por si lo necesiten

image
hace 30 días   NeoRazorX   [admin]
Hola, el mensaje de error indica que no se encuentra la función simplexml_load_string(). Función que viene dentro de la extensión simplexml de php. Función sin la cual no se puede instalar FacturaScripts, porque ya comprobamos en el instalador que esté presente esta extensión.

¿Has instalado FacturaScripts en un equipo y luego lo has movido a otro?
hace 28 días   aptelcsc_f74d39
He actualizado... bueno el sistema se actualizo y creo que ha ocurrido el error al hacer esto. Solo que no se como solucionarlo, ya he probado con actualizar php e instalar dicha funcion pero parece que ese no es el problema. Parece que es en la definicion de la funcion nada mas.
hace 28 días   aptelcsc_f74d39
problema resuelto.. gracias. Lo solucione añadiendo los repositorios de PHP en ubuntu 17.10 y reinciando PHP
hace 28 días   NeoRazorX   [admin]
Vale, entonces soy yo el que ha metido la pata. Cuando he leído actualizar el sistema pensaba que te referías a FacturaScripts, no a Ubuntu.

Así que lo que ha pasado es que has actualizado Ubuntu y se ha instalado PHP 7, que no lleva las mismas extensiones por defecto que la versión 5. La solución es instalar las extensiones que faltan:
sudo apt-get install php-xml php-mbstring php-zip php-bcmath php-curl
hace 27 días   aptelcsc_f74d39
gracias amigo
No se pueden hacer más comentarios. Mejor escribe una nueva pregunta

aptelcsc_f74d39

EC  usuario


OFERTA

Plugin import_export_csv

Financiación extra

6 patrocinadores

Este mes se han realizado un total de 6 aportaciones económicas para acelerar el desarrollo del proyecto.

11% Complete

55 € este mes.

+5 € +4 votos

+25 € +20 votos




Soporte:

FacturaScripts es software libre y gratuito, pero si lo que busca es asesoramiento y soporte profesional, use la sección soporte.

  Soporte

Redes sociales:

Puede encontrarnos en las principales redes sociales. Y también en google+.





© 2013-2017 FacturaScripts