Esta consulta es de hace 4 años. Tenga eso en cuenta.
Esta web utiliza cookies propias y de terceros para su funcionamiento. ¿Aceptas? Leer más
info_012e53
info_012e53
Pregunta cerrado

Buenas, el otro día, pruebas arriba y pruebas abajo,...

Buenas, el otro día, pruebas arriba y pruebas abajo, resulta que reinstalé todo el sistema Debian de mi equipo, monté todo de nuevo y preparé la plataforma para utilizar FacturaScripts tal y como se detalla, todo bien. Ahora, cuando intento incorporar los plugins, el plantillas_pdf de pago, por ejemplo, no me lo carga ni incorpora al listado de plugins, tampoco los plugins adquiridos por metas conseguidas en el plan. ¿qué puede ser?

Resulta que si recupero (de la copia de seguridad) todo el árbol de directorios, lo cuelgo en el www/html (blah blah blah), base de datos MySQL recuperada y tal, funciona de nuevo, pero ... me da un poco de miedo este punto ... ¿alguien me puede dar una pista? tema de permisos de usuario no creo, está igual que antes, el plugin está bien descargado, la base de datos igual, con los permisos correspondientes (además importa la copia perfectamente)

Toy perdido ... a lo Nemo. De momento tiro con el apaño mencionado, pero creo que algo se me escapa para hacerlo bien desde cero (y sí, he seguido el tutorial, tampoco es tan complicado montar el tema). ¿Es correcto que haya versiones de 'páginas' desde la 2015.040 a la 2015.046? (en mi caso particular, que he ido actualizando conforme salían las cosas)

Saludos, perdón por el rollo.

España   21-12-2015 22:57:36   26-12-2015 19:22:11   1   [NeoRazorX]

Comentarios
NeoRazorX
Un poltergeist.
Puedes añadir plugins desde la pestaña descargas, ¿Pero no añadir un zip?
shawe.ewahs+fs_f74d39
Que te aparezcan con versiones diferentes ocurre porqué todavía no has accedido a esas páginas.

Abre las páginas con versiones viejas y recarga esa lista y verás como ha cambiado. No te preocupes por eso, porque se refrescan ciertos datos a medida que se usa, pero no te afecta en nada.
info_012e53
Ok, gracias, lo del refresco de versiones, OK.

Sí Carlos, los plugins que añado desde web, sin problemas, los adquiridos de pago o del plan, no me deja (antes me pedía clave para el Plantillas_Pdf por ejemplo, ahora no), seguiré investigando, no le déis más vueltas, será algo mío, de lo contrario, alguien más lo hubiese comentado.
info_012e53
Ups... ¿podría ser que en lugar de utilizar el usuario 'admin' con el que trabajaba antes ahora utilizo otro? es la única diferencia perceptible que veo... ¿el plugin va asociado a un email o nombre de usuario para instalarse?
NeoRazorX
Ahora si que me he perdido ¿Tienes los archivos zip si o no? El email o que sea un plugin de pago no tiene nada que ver para instalar un plugin. Y nunca se pide una contraseña para instalar un plugin.
info_012e53
Carlos, sí que tengo los plugins en ZIP, no me deja insertarlos, examino, acepto y no aparece en la lista después, algo extraño, lo único que hice de una instalación a otra es cambiar el usuario (de admin a alberto), eso sí, empezando desde cero, por lo que no debería de arrastrar configuración anterior alguna.

Lo de la clave, cuando adquiri el plugin de plantillas_pdf me llegó un email con una clave para poderlo instalar, ahora si no hace falta, ya no lo sé.

De todas las formas, no pierdas tiempo por esto, seguro que es cosa de mi instalación, voy tirando con el apaño mencionado de copiar todo el árbol de directorio y recuperando la base de MySQL sobre la misma.

Saludos. Podéis cerrar el ticket, si doy con el chiste, lo contaré a modo de experiencia propia.
NeoRazorX
¿Pero no aparece ningún mensaje de error?
info_012e53
Así es, ni mensaje de correcto, ni mensaje de error, vuelve a la pantalla de plugins donde no aparece el que se supone que he cargado. La verdad, muy extraño. Este fin de semana volveré a tirar toda la instalación y base de datos para probar a ver. Ya te diré. Yo lo voy a poner en producción para 2016 para mi actividad laboral, así que lo tengo que trillar de arriba a abajo para controlar cualquier posible problema. Gracias por el interés, pero repito que lo más probable sea algo en lo que yo esté patinando.
joenilson_f74d39
Has revisado si en las configuraciones del php el max_file_upload esta en un valor aceptable?, talvez el ZIP es más grande de lo permitido.

Otra puede ser que el archivo zip tenga caracteres extraños o le hayas colocado un nombre con espacios, y por ultimo seria validar que tu nuevo server este con UTF-8, que si esta en latin o algun encoding diferente puede hacer que el archivo ZIP se este creando con caracteres no reconocidos.

Mas aya de eso, lo que puedes hacer es abrir una terminal y ejecutar el siguiente comando: tail -f /var/log/apache2/error.log y ver si te da algun error por alli a la hora de cargar el zip.

Y si no funciona, pues talvez este año no te has portado muy bien y papa noel te está dando tu regalo de navidad al estilo grinch,

El fin
info_012e53
Bueno, confirmo lo que decía (me he adelantado al finde), no puedo añadir plantillas_pdf.zip de ninguna manera, he creado todo desde 0, CRM.ZIP y SERVICIOS_PREMIUM.ZIP sin problemas, con plantillas_pdf.zip, lo que decía, ni da error ni nada, vuelve a a pantalla de plugins y no aparece (como los otros SÍ que hacen).
Tengo una Debian Jessie 8, Mysql y Apache funcionando bien, UTF-8, no es por usuario, pues ahora tengo el Admin por defecto.
Lo único que sospecho ... ¿tamaño de archivo? ya que pone límite (en mi equipo) de 8Mb, el plantillas_pdf.zip son 4,5Mb (¿pero descomprimido?) no sé, es un lío, así que sigo con mi 'chapuza' funcional dado que no encuentro la forma de coger este lío.
Repito, base de datos nueva, directorio de instalación nuevo, todo desde cero, igual resultado ... pero ¿qué he hecho mal? la primera vez lo hice así y funcionó todo, tras alguna actualización del plantillas_pdf parece que se me ha petado.

En fin, lo dicho, que quede como anécdota, pues si me pasa sólo a mí, es porque tendré algo que no chuta.

Saludos y que paséis unas felices fiestas y fin de año.
info_012e53
Perdón, Carlos, igual te aclaro algo más, si descomprimo previamente el plantillas_pdf.zip y lo muevo a la carpeta plugins de la instalación de FacturaScripts, poniendo permisos de www-data, FUNCIONA y lo puedo activar, así que ... creo que es algo de permisos... pero ¿por qué CRM y SERVICIOS_PREMIUM sí y PLANTILLAS_PDF, no?

Misterios. Saludos.
shawe
Mi plugin de automoción ocupa algo más de 100MB y había gente reportando un problema parecido, no sólo por el tamaño de archivo máximo aceptado, sino por el tiempo máximo que PHP tiene para realizar operaciones.

Mira de editar el archivo: /etc/php5/apache2/php.ini e incrementar este valor "max_execution_time" a el doble del valor por defecto. O sino quieres editar el php.ini a modificar el ".htaccess" de la carpeta de FS añadiendo esto:

<IfModule mod_php5.c>
php_value max_execution_time 300
</IfModule>

Pero lo ideal para intentar descubrir que ocurre es lo que te dijo joenilson, ejecutas en un terminal el comando: "tail -f /var/log/apache2/error.log" e intentas cargar ese plugin, al fallarte deberías ver algún mensaje de error en donde ejecutaste ese comando.
sisumgesa_eda710
sino yo lo desconprimi el zip en el directorio de pluying y listo arriba o abajo
lo activas y a trabajar
NeoRazorX
Yo diría que el problema es la configuración del apache. En el archivo /etc/apache2/apache2.conf

Deberías tener esta sección:
<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted
</Directory>


Para decirle al apache que lea los .htaccess que modifican la configuración.
info_012e53
Gracias por las aportaciones amigos, con el 'AllowOverride All' que comenta Carlos me ha dejado cargar el PLANTILLAS_PDF. Así pues, cerramos el tema. Perdonad la paliza. Gracias a todos.

Eso sí ... el gusanillo de saber por qué sólo me sucede con el plantillas_pdf quedará en el limbo de la duda, jeje

Cerrado
otros
Título Tipo
info_012e53
Hola, muy buenas, aquí haciendo pruebas con la actual beta 9 de Facturascripts 2018, me sucede una cosa que antes no me sucedía, al instalar desde cero en mi hosting (Strato) me tira atrás en el...
cerrado 28-10-2018 01:36:44
Idea 0
info_012e53 NeoRazorX
Buenas, una pregunta tonta, igual ya anda respondida por ahí. Estoy haciendo pruebas con la versión FS 2018, he desplegado en mi servidor propio local (GNU/Linux Debian) y aparentemente todo se...
cerrado 05-12-2017 17:35:40
Pregunta 1
info_012e53 NeoRazorX
Buenas noches, hoy al ir a actualizar el plugin CRM me ha salido un error en el fichero UPDATE.ZiP, cosa que nunca me había pasado. Revisando FAQ y demás he revisado mi sección de Claves y...
cerrado 10-11-2017 23:33:54
Pregunta 1
info_012e53
Hola, son interesantes los cambios realizados en esta última actualización de plantillas_pdf pero: 1) Ha sido una pena (¡ojo! Para mí) perder el justificado del texto de pie de documento (en mi...
cerrado 22-12-2016 00:59:45
Idea 0
info_012e53 info_97
Creo que desde la última actualización (2016.025) no puedo enviar documentos (presupuestos, albaranes, facturas...) por email (con el botón Enviar y luego plantilla). Tengo que generar el PDF y...
cerrado 13-11-2016 21:45:39
Error 3
info_012e53 info_97
Desde la última actualización (2016.019), al hacer una factura, me dice en la cabecera (en ROJO) que 'El importe del asiento es distinto al de la factura', la factura está bien, importes...
cerrado 15-09-2016 08:29:16
Error 5
info_012e53 info_97
Hace poco comenté el tema de la 'rotura' del 'https' dentro de Panel de Control y del Updater, se corrigió cuando lo comenté la primera vez salvo el Updater, ahora con la nueva...
cerrado 08-06-2016 09:18:33
Pregunta 4
info_012e53 info_97
Buenas, esto es sólo una pregunta que no reporta error alguno. Dispongo de FacturaScripts en mi hosting (en Strato) y todo funciona de maravilla (salvo que no me dan CRON si no paso a un hosting...
cerrado 27-05-2016 14:30:49
Pregunta 2
info_012e53 NeoRazorX
Con la genial incorporación de la página y número total de páginas de documento, tengo un pequeño problema estético al imprimir con plantillas_pdf en su plantilla 'antigua', en el PDF sale...
cerrado 05-04-2016 16:53:38
Pregunta 4
info_012e53 NeoRazorX
Después de un tiempo con problemas con el nuevo Dashboard del Adminlte, me autocontesto y comento por si a alguien le había pasado. Hice mal (perdón Carlos) en abrir el error en los comentarios de...
cerrado 19-03-2016 12:22:24
Error 1
info_012e53 info_97
Creo que sería positivo (y visualmente legal) que, al indicar el IBAN de una cuenta apareciera todo en la misma linea, me explico: En plantillas_pdf (yo uso la 'genérica' pero creo que...
cerrado 16-02-2016 12:51:44
Idea 2
info_012e53 NeoRazorX
Hola de nuevo, casualidad o no, después del Update de hace unas horas, no me deja loguearme en la aplicación (y pongo bien el usuario y contraseña, no ha cambiado desde el principio). Me dice...
cerrado 25-01-2016 13:56:36
Pregunta 3
info_012e53 info_97
Buenas, cuando he ido a descargar el Libro Mayor desde Informes-Contabilidad, me he encontrado un problema con el CSV, que creo es un tema de codificación de caracteres o similar. Tengo un...
cerrado 24-01-2016 00:13:36
Pregunta 4
info_012e53 info_97
Buenas, aunque ya se lo he comentado a nivel interno (email) a Carlos, yo normalmente pongo una coletilla de la protección de datos al final de todos los documentos (presupuestos, albaranes,...
cerrado 07-01-2016 07:46:29
Pregunta 2
info_012e53 info_97
Buenas, Me ha parecido (vamos, lo he probado un par de veces, sinceramente) que no puedo emitir un presupuesto de venta de un artículo que tenga stock a 0 (en la ficha prohíbo la venta si no hay...
cerrado 28-12-2015 10:23:55
Idea 4
info_012e53 shawe
¿Sería factible en el diseño de plantillas_pdf llevar la línea de totales a una posición X? Al igual que el 'pie de página' tiene una posición marcada y ajustada a nuestro tamaño de papel....
cerrado 09-10-2015 08:19:50
Idea 1
info_012e53 oki4free_103
Los autónomos, cuando hacemos retención de IRPF en servicios (yo usos dos series distintas, una de servicios con IRPF y otra de ventas sin IRPF), obviamente descontamos de la base el IRPF y...
cerrado 07-10-2015 16:49:51
Idea 3
info_012e53 info_97
Puede que me pase sólo a mí pero, cuando defino en el Panel de control - Avanzado que quiero la "coma" como separador decimal y el "punto" como separador de millares, me lo...
cerrado 29-12-2015 10:15:03
Pregunta 2