Esta web utiliza cookies propias y de terceros para su funcionamiento. ¿Aceptas? Leer más
Programación

facturascripts.ini

Este archivo indica a FacturaScripts los datos y requisitos del plugin.

version = 1
require = 'facturacion_base'
min_version = 2017.901

version

Indica la versión del plugin, debe ser un número entero. Nada de decimales, ni letras.

version_url

Opcional. Una URL donde consultar este archivo facturascripts.ini actualizado, así el actualizador puede comprobar cuando hay actualizaciones.

version_url = 'https://raw.githubusercontent.com/NeoRazorX/facturacion_base/master/facturascripts.ini'

update_url

Opcional. Una URL de donde descargar la nueva versión del plugin

update_url = 'https://github.com/NeoRazorX/facturacion_base/archive/master.zip'

require

Opcional. Indica que el plugin o plugins imprescindible para el funcionamiento de este plugin. Si son varios plugins se indicará separando por comas:

require = 'facturacion_base,CRM'

min_version

Versión mínima de FacturaScripts que necesita este plugin. Ejemplo:

min_version = 2017.901

idplugin

Opcional. Si el plugin está publicado en la web, suele ser necesario indicar el idplugin. Este id será el que indique en la web una vez lo hayas publicado.

idplugin = 87

wizard

Opcional. Indica qué controlador del plugin se debe ejecutar al activar el plugin. Ejemplo: ejecutar el controlador base_wizard al activar el plugin.

wizard = 'base_wizard'

Importante: al usar wizard FacturaScripts no activará todos los controladores del plugin. Deberá hacerlo el controlador indicado en el wizard. Ver controlador base_wizard para más detalles.